ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • [Flutter 시작] 1. 설치하기(Windows 환경)
    [Developer]/Flutter 2018. 12. 17. 01:27

    ** 이 글은 https://flutter.io 의 안내 페이지에 있는 내용을 번역 및 재구성한 내용입니다.

    참고바랍니다.


    (출처: https://flutter.io/docs/get-started/install/windows)



    시스템 필요조건

    Flutter를 설치하고 실행하기 위해서는, 최소한 아래의 요구조건에 맞추어 개발 환경을 구성해야 합니다.

    - OS: 윈도우 7 SP1 혹은 그 이상(64비트)

    - 디스크 용량: 400MB(통합개발환경이나 개발도구들을 위한 용량은 포함하지 않은 상태)

    - 도구: Flutter는 사용자 환경에서 이용가능한 툴에 따라 종속됩니다.

    * Windows PowerShell 5.0 혹은 그 이상(윈도우 10에서는 이미 설치되어 있습니다.)

    * Git for Windows: 특히 Use Git from the Windows Command Prompt 옵션을 사용해야 합니다.


    만약 이미 Git for Windows가 설치되어 있다면, 커맨드 프롬프트나 파워쉘에서 git 명령어를 사용할 수 있도록 만들어야 합니다.



    Flutter SDK를 가져오기

    1. 아래의 링크에서 Flutter SDK의 최신 stable release 버전에 대한 번들을 가져옵니다.

    (https://storage.googleapis.com/flutter_infra/releases/stable/windows/flutter_windows_v1.0.0-stable.zip)

    만약 다른 빌드 버전을 원한다면, SDK Archive 페이지를 확인하면 됩니다.(https://flutter.io/docs/development/tools/sdk/archive)


    2. zip파일을 압축해제하고, Flutter SDK를 설치하고자 하는 위치에 이동하면 됩니다. 예를들면 C:\src\flutter와 같은 디렉토리로 하면 됩니다. 다만, C:\Program Files\와 같이 권한상승이 필요한 디렉토리에는 설치하지 마십시오.


    3. flutter_console.bat 파일을 flutter 디렉토리에 위치하고, 그것을 더블클릭하시면 됩니다.(압축해제하면 그 안에 포함되어 있습니다.)


    이렇게 완료했다면, Flutter 콘솔에서 Flutter 명령을 실행할 준비가 완료된 상태입니다.


    PATH 갱신하기

    만약 Flutter 명령어를 일반적인 윈도우 콘솔에서 실행하고 싶다면, 아래의 단계에 따라 Flutter를 PATH 환경변수값에 추가하면 됩니다.


    시작버튼의 검색창에서 "환경"을 입력하고, 계정의 환경 변수 편집을 선택하세요.


    사용자 변수의 아래 있는 Path의 요소를 확인하세요.


    i) 만약 Path가 있다면, 그곳에 "설치된위치\flutter\bin" 디렉토리의 풀 경로를 적어주세요. 다른 값과는 쎄미콜론(;)으로 구분하면 됩니다.


    ii) 만약 Path가 없다면, Path라는 변수를 추가하고 동일하게 "설치된위치\flutter\bin" 디렉토리의 풀 경로를 적어주세요.





    flutter doctor 실행하기

    콘솔창에서 PATH에서 지정한 flutter 디렉토리로 이동하여 아래의 명령어를 실행시키면 설치를 완료하기 위해 필요한 의존성을 볼 수 있도록 도와줍니다. 플랫폼 무관하게 동작합니다.(제가 확인결과 PATH에 추가만 되어있으면 사실 어느 디렉토리에서 실행하든지 상관없었습니다.)


    C:\src\flutter> flutter doctor


    이 명령어는 당신의 환경을 체크해주고, Flutter 설치의 상태에 대한 보고서를 보여줍니다. 다른 소프트웨어의 설치나 어떠한 작업이 필요하다면 그것의 결과물을 확인해보세요.(아래에서 굵은 글자로 보여집니다.)


    예를들면)


    [-] Android toolchain - develop for Android devices

        • Android SDK at D:\Android\sdk

        ✗ Android SDK is missing command line tools; download from https://goo.gl/XxQghQ

        • Try re-installing or updating your Android SDK, 

          visit https://flutter.io/setup/#android-setup for detailed instructions.


    다음 섹션에서는 이러한 작업을 수행한 뒤 설치 프로세스를 완료하는 방법에 대해 설명하고 있습니다. 누락된 종속성을 설치했으면, flutter doctor 명령을 다시 실행하여 모든 것을 올바르게 설정했는지 확인할 수 있습니다.


    참고로, 디바이스가 연결된 상태에서 개발해야 막힘없이 중간에 테스트를 진행하며 개발할 수 있으므로, 디바이스가 연결되지 않은 것도 flutter doctor로 검출됩니다. 그럴경우 디바이스를 USB로 연결하시거나, 에뮬레이터라도 실행해주세요!


    Flutter 도구는 Google Analytics를 사용하여 Feature 사용통계 및 기본 오류 보고서를 익명으로 보고합니다. 이 데이터는 시간이 지남에 따라 Flutter 도구를 개선하는데 사용됩니다. Analytics는 첫 번째 실행시에나 Flutter 환경설정과 관련된 모든 실행시에는 전송되지 않으므로 데이터가 전송되기 전에 분석하기 위한 정보수집을 거부할 수 있습니다.


    보고 기능을 사용하지 않으려면 flutter config --no-analytics를 입력하고 현재 설정을 표시하려면 flutter config를 입력하면 됩니다. Google의 개인정보 취급방침은 다음과 같습니다. 다음을 참고하십시오.


    www.google.com/intl/en/policies/privacy



    안드로이드 설정

    참고사항: Flutter는 Android 플랫폼의 종속성을 제공하기 위해 Android Studio의 전체 설치를 사용합니다. 하지만, 이 외에도 많은 수의 editor에서 Flutter app을 작성할 수 있습니다. 이것에 관해서는 다른 글에서 논의될 것입니다.


    Android Studio 설치하기

    1. Android Studio를 다운로드하고 설치하십시오.(https://developer.android.com/studio/)

    2. Android Studio를 시작하고, Android Studio 설치 마법사를 진행하십시오. 이것은 Android용으로 개발할 때 Flutter가 필요로하는 최신 Android SDK, Android SDK Platform-tools 및 Android SDK Build-tools를 설치합니다.


    당신의 Android 기기를 설정하기

    당신의 Flutter app을 실행하고 테스트하기 위해 Android 기기를 준비하세요. 안드로이드 기기는 Android 4.1(API Level 16)이거나 그 이상으로 준비해야 합니다.


    1. 당신의 기기에서 개발자 옵션을 활성화 하고 USB 디버깅을 활성화하세요. 자세한 지침을 참고하려면 Android 문서를 참고하세요.(https://developer.android.com/studio/debug/dev-options)

    2. (윈도우 한정) Google USB 드라이버를 설치하세요.(https://developer.android.com/studio/run/win-usb)

    3. USB 케이블을 이용하여 당신의 컴퓨터에 당신의 기기를 연결하세요. 컴퓨터가 기기에 접근할 수 있도록 인증하는 화면이 뜨면, 승인을 해주세요.

    4. 터미널에서 flutter devices를 실행하여 연결된 Android 기기가 Flutter 인증된 것인지 검증하세요.


    기본적으로 Flutter는 Android SDK에 있는 버전의 adb tool을 사용합니다. 만약 다른 Android SDK의 설치된 버전을 이용하기를 원한다면, 반드시 ANDROID_HOME을 환경변수로 하여 값에 설치된 디렉토리를 지정해주세요.

    Android 에뮬레이터를 설정하기

    flutter app을 실행하고 테스트하기 위해 Android 에뮬레이터를 이용하려면 다음의 단계를 따르면 됩니다.


    1. 컴퓨터의 VM 가속화를 활성화 하세요.

    2. [Android Studio > Tools > Android > AVD Manager]를 실행하고 Create Virtual Device를 선택하세요.(Android 서브메뉴는 오직 Android Project 내부에서만 표현됩니다.)

    3. Device definition을 선택하고 Next를 누르세요.

    4. 에뮬레이트하기 원하는 Android 버전 하나 혹은 더 많은 시스템 이미지를 선택하세요. x86이나 x86_64를 추천합니다.

    5. 에뮬레이터 성능을 위해서는 Hardware - GLES 2.0을 선택하고, hardware acceleration을 활성화 하세요.(https://developer.android.com/studio/run/emulator-acceleration)

    6. AVD 환경설정이 맞는지를 점검하고, Finish를 누르세요. 더 많은 스텝에 대한 정보를 얻기 원한다면 Managing AVDs를 참고하세요(https://developer.android.com/studio/run/managing-avds)

    7. Android Virtual Device Manager 안에서 toolbar의 Run을 클릭하세요. 에뮬레이터가 시작되고 선택된 OS 버전과 기기의 기본 그림이 화면에 표시될 것입니다.



    댓글 0

Designed by Tistory.